[Delays] Guam
Incident Report for Checkr Global Data Status
Resolved
This incident has been resolved.
Posted Oct 31, 2022 - 21:20 UTC
Monitoring
10/18/2022: The Guam source is understaffed due to Covid, please expect some delays. This only affects criminal searches. We will continue to monitor this and notify you of any changes.
Posted Oct 24, 2022 - 16:37 UTC