[Closure] Libya Criminal Searches Unavailable
Incident Report for Checkr Global Data Status
Resolved
Libya criminal product has been reinstated and searches will resume.
Posted Sep 09, 2024 - 13:06 UTC
Monitoring
Libya Criminal searches are currently unavailable due to the political situation. We are continuing to monitor and will notify you of any changes.
Posted May 21, 2024 - 18:42 UTC