[Delay] - Puerto Rico

Incident Report for Checkr Global Data Status

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 17:33 UTC

Update

Expect delays due to court closures for Holy Week from 4/14 - 4/18.
Posted Apr 18, 2025 - 16:43 UTC

Update

Expect delays due to court closures for Holy Week from 4/14 - 4/18.
Posted Apr 14, 2025 - 18:05 UTC

Monitoring

Expect delays due to court closures for Holy Week from 4/14 - 4/18.
Posted Apr 09, 2025 - 17:02 UTC