Croatia Criminal Searches Delayed
Incident Report for Checkr Global Data Status
Resolved
The strike in Croatia is over and criminal searches are back up and running. Please expect some delays as these are being completed.
Posted Aug 29, 2023 - 19:54 UTC
Update
The strike in Croatia is still ongoing and we currently do not have an ETA for when criminal searches will be available. We are continuing to monitor the situation and will update you if there are any changes. Please find more information on the strike here: https://n1info.hr/english/news/strike-of-judicial-officers-has-begun/.
Posted Jul 31, 2023 - 16:57 UTC
Monitoring
Criminal searches in Croatia are currently delayed due to government workers being on strike. We are working with them to prioritize where possible, but most are unable to be completed at this time. There is currently no ETA provided for when the strike will be over, but we will update you as soon as we have additional information.
Posted Jul 24, 2023 - 17:30 UTC