[Delays] Czech Republic
Incident Report for Checkr Global Data Status
Resolved
This incident has been resolved.
Posted Oct 23, 2023 - 17:17 UTC
Monitoring
The Czech Republic criminal searches are experiencing delays due to technical maintenance on their portal. They expect normal operations to resume on Friday, 10/20/2023. We will continue to monitor this and notify you of any changes.
Posted Oct 16, 2023 - 16:21 UTC