[Planned Outage] Quebec Driver Checks
Incident Report for Checkr Global Data Status
Resolved
This incident has been resolved.
Posted Feb 16, 2023 - 15:39 UTC
Monitoring
Quebec driver database will be offline between January 30, 2023, to February 16, 2023, for scheduled maintenance. This affects drivers license verifications and International MVR (Canada). All pending Quebec orders will be queued to run beginning on February 17, 2023.
Posted Jan 28, 2023 - 00:02 UTC