[Closure] Greece
Incident Report for Checkr International Data Status
Resolved
1/24/2023: Greece is now back up and orders are now able to be processed. Please expect some delays as the researchers work through the orders.
Posted Jan 24, 2023 - 22:45 UTC
Monitoring
1/20/2023: The Greece authorities have an unexpected shutdown of their system. They are working on getting it fixed, but we are unable to process orders at this time. We will continue to monitor this and notify you of any changes.
Posted Jan 20, 2023 - 22:37 UTC