Expect delays due to ongoing conflict and staffing shortages.
Posted Apr 22, 2025 - 17:44 UTC
Update
Expect delays due to ongoing conflict and staffing shortages.
Posted Apr 18, 2025 - 16:31 UTC
Update
Expect delays due to ongoing conflict and staffing shortages.
Posted Apr 14, 2025 - 18:12 UTC
Update
Expect delays due to ongoing conflict and staffing shortages.
Posted Apr 09, 2025 - 17:19 UTC
Update
As of 12/1/2023 - Expect delays due to ongoing conflict and staffing shortages. We are monitoring the situation.
Posted Feb 20, 2025 - 19:07 UTC
Update
Expect delays due to ongoing conflict and staffing shortages.
Posted Feb 06, 2025 - 18:45 UTC
Update
Searches in Israel are still experiencing delays due to the political situation. However, searches in the Palestinian Territories are currently suspended completely. We will continue to monitor these countries and update you when we hear more information.
Posted Dec 21, 2023 - 21:25 UTC
Monitoring
Due to the current political developments, we are expecting delays in Israel and Palestine for criminal and verification products. Because of the uncertainty of the political events we don't have any additional information as of now, but we will update as more information becomes available.