[Delays] Mexico
Incident Report for Checkr Global Data Status
Resolved
Searches for Mexico Criminal should now expect an average turnaround time of 8-10 days. All documentation has been updated and we will notify you if there are any changes.
Posted Jan 22, 2024 - 17:49 UTC
Update
Mexico Criminal searches are still delayed due to system errors. We currently don't know when the ETA should be back to normal, but we will continue to monitor this.
Posted Dec 14, 2023 - 23:15 UTC
Monitoring
We are experiencing delays for Mexico Criminal searches due to systematic errors. Unfortunately, we don't have many details, but will update you as we find out more information.
Posted Nov 17, 2023 - 22:11 UTC